Redm crashes after selecting character

RDR2 version? 1.0.1491.18
Up to date? yes
Legit or Pirate copy? Legit
Steam/Epic Games/Social Club? Social Club
Windows version? 10, 19044.2846
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any)

System specifications Ryzen 7 3700X, 32GB RAM, AMD Radeon RX 5700
What did you do to get this issue? I joined the Ranch roleplay server selected my character and then it crashed
What server did you get this issue on? Ranch Roleplay but tried in multiple where I got the same crash
Latest CitizenFX_log file
CitizenFX_log_2023-05-05T195935.log (185.4 KB)

.dmp files/report IDs
101121db-900f-407b-b44f-580d6141dda9.dmp (8.7 MB)

If an issue with starting:
RDR2 folder screenshot

RDR2/x64/dlcpacks screenshot

Filepath to RedM folder C:\Users\Name\AppData\Local\RedM
RedM client folder screenshot

Did you try to disable/uninstall your Anti-virus? Yes
Did you start Rockstar Games Launcher not as admin? I started it as admin

Also add what you already tried so far. So far I have deleted my SGA files multiple times .changes my setting in rdr2 which starts fine. changes vulkan to directx12 and back. re-installed redm deleted all of the files related to redm and server except for rdr2 itself which I did verify a few times and tried release, beta and latest versions of redm

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

Hi I have the problem I can’t get to the server I tried a lot of things from youtube but still not working and the problem I can connect to a lot of servers but in one where I want to play I can’t connect I have a crash after all downloads
CfxCrashDump_2023_05_06_18_24_48 (1).zip (1.7 MB)