Problems with running server under mono

I downloaded your server and tried run it with mono.
First time I ran it it gived me error about resource directory not found, so I copied all directories and config to the bin folder.
But now I have another error:

  • 2016-06-29 10:23:50.0572|ERROR|CitizenMP.Server|Error creating script environment for resource initial: Could not find file “/var/fivereborn/bin/resources/initial/__resource.lua”.

Thanks for help

Create a new notepad file, rename it to __resource.lua that will fix it.

Next time please follow the entire tutorial. The tutorial states you have to copy the files.

Boss’s answer is the right one actually. Under certain Linux versions (I use CentOS 7 on my server), when trying to reference a non-existent file, the system will throw a hard error and that can cause the app to terminate. Some other versions (like Ubuntu), throw a soft error and allow the app to keep running until something else causes it to crash.

it’s normal for the server operation to return ENOENT on some files; if your distribution terminates software rather than returning the error directly it’s clearly misconfigured.