Problem with installing mods (mainly cars)

So, i’ve been trying to setup my own FiveM server and got some problems. Basically, the server is working fine, but I want to install some mods on it and had some complications with file formats (and understanding them)

Tried to install some vehicles first, then I realized that I can’t simply install them because their format was incompatible with the FiveM at all. Some of them are “.meta”, “.rpf”, “yft”, etc. Can’t take any conclusions of which one of these are correct. Downloaded some programs like FXI and I’m still having problems. I searched the entire internet looking for some solutions and the results were like too outdated or didn’t came to a precise conclusion. Any sugestions?

obs.: FXI can’t install .rpf files

(btw sorry for my bad English)

Did you tried this:

not before. I followed this guide early today and got another problem. Everytime I try to log into my server I got this:

Error GTA5+8D165B

[Main Instruction]

A game error (at 00000001408d1660) caused FiveM to stop working. A crash report has been uploaded to the FiveM developers.
If you require immediate support, please visit and mention the details below.

Corrupt game data. Please reboot, verify the game data, or reinstall the game. For more information, please visit:

[^] Hide details  [Save information] [Close]

[Expanded Information]
Crash signature: fivem.exe+8D165B
Report ID: ... [uploading?] (use Ctrl+C to copy)

Any sugestions?

Steps already done:
Deleted “cache” folder at FiveM Application Data.
Deleted whole GTA5 folder and reinstalled it (steam version)
Updated “cache” folder by FiveM.exe
Verified cache at GTA5’s steam properties.

The error’s caused by the mod itself (Removing it solves the problem, but that’s not the path we should take, right?)

c13d1e15-3860-4daf-a7c2-c10c05879551.dmp (5.5 MB)
CitizenFX.log (88.9 KB)