KeepInput is stuck on true

Hi,

Recently FiveM has been keeping input in the game when NUI is open. Essentially the same effect as when you use SetNuiFocusKeepInput(true), but it’s happening permanently.

I’ve tried both Canary and Release, I’ve tried restarting, I’ve tried running it on clean servers (unmodded except for a single resource to open an NUI), I’ve tried reinstalling FiveM completely (and nuking all the folders in AppData).

It happens in both full screen and windowed mode.

Other people running exactly the same code as me are not experiencing this problem.

I’ve attached a video showing this problem. The camera view should not be moving.

Then provide reproduction steps, since it seems like a system anomaly and not a bug.

Might be a game version issue? Have you tried running it on 1604 or maybe 2189?

Having tried everything, and having no idea how to reproduce, I’ve fixed this by doing a full reinstall of windows.

I’ve heard that quite a few users experience this issue, but I can’t find a common theme.

… game mouse input type? :stuck_out_tongue:

Seems to be it.

Weird, I haven’t touched any settings like that.

Do you know where this is actually ‘saved’ in GTA? Because I’d reinstalled GTA and cleared out any related AppData file that I could find.

(Oh well, I needed a clear out anyway)