Infinite Loading Screens on Servers

GTA V version? Build 2020 Online 1.51
Up to date? Yes
Legit or Pirate copy? Legit
Steam/CD/Social Club? Steam copy
Windows version? Win 10 Pro 1903
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any) https://ibb.co/PGVJfzK
System specifications 8600K CPU, 1070ti GPU, 16GB 3200MHz RAM, 1TB SSD
What did you do to get this issue? Had to reinstall Windows due to drive failure. FiveM had been working prior to this. To get this issue now, all I have to do is attempt to join any server. I’m using RSM as an example as it’s one I used often before this, but no servers are loading. They all get stuck on their loading screens, and F8 indicates no progress past this point.
What server did you get this issue on? RSM Freeroam
CitizenFX crash zip file N/A
CitizenFX.log file CitizenFX_log_2020-09-09T063606.log (47.7 KB)
.dmp files/report IDs

If an issue with starting:
GTA V folder screenshot


GTA V/update/x64/dlcpacks screenshot
Filepath to FiveM folder C:\Games\FiveM\FiveM.exe
FiveM client folder screenshotFiveM Folder and
Which antivirus/firewall software are you using? Malwarebytes
Did you try to disable/uninstall your Anti-virus? Yes

Also add what you already tried so far.
Reinstalled GTA, Reinstalled FiveM, removed the caches.xml and everything in caches except game, updated GPU drivers, multiple restarts, used a VPN, moved FiveM to another location so Windows asks for permission for it to access the Internet again.

Any server I join gets to “[glue] Network connected, triggering initial game load…”. No servers load past this point at all. Single player from the FiveM menu gets to that mini-game where you control a guy from the top-down, but doesn’t get any further than that. Trying to play single player patch 1.27 from the FiveM folder results in an error “Assertion failure: m_matches.size() == expected (C:\gl\builds\edf06b9b\0\cfx\fivem\code\client\shared\Hooking.Patterns.h:125)”

All of this started happening since I reinstalled Windows. I did a fresh install of everything, including GTA and FiveM. I can see that this problem has happened to others, but I cannot find a solution to this problem anywhere.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

FIX:

YMMV, but the fix for me was to delete the GTA5 folder located at %userprofile%\Saved Games\CitizenFX
This allowed single player to load, and now servers load.
Appears my save game had been corrupted somehow.