[How-to] Properly stream map files without missing objects!

Hey everyone,

I have seen a few people on here asking on why their .ymap files don’t work at all or have some minor issues. First of all you will need to head over to my github and download the following repository below. Broken .ymap files can be caused by many reasons and here is all my fixes. There will be 2 sections on this thread, the first section will be about invalid objects and them not loading in, the second section will be about turning .xml files into .ymap files but saying an error when using ME2YM.

Github: https://github.com/bxrksggs/mb_addons

First of all you will need to head to my github listed above and have it as a normal resource. You will need to start this resource before any maps to stop unexpected errors in .ymap files when viewing them in-game, start mb_addons in your server.cfg. That will fix the missing objects issue (most of them) I will keep updating that folder for newer objects.

Secondly is a ME2YM error when turning .xml files into .ymap once you try and import it, a pop-up box will appear with the error “Fail to read file” this is because you will have a pickup object, so you load up the .xml file in a text editor and press CTRL + F now you type pickup. You will find 1 or multiple objects (normally one after each other) You want to find the <object> for the pickup object and delete all the way to the end of it that will end with now you save the file and put it back into ME2YM!

Credit: Robbster to teach me about the ME2YM error, its here to promote it!

If you have any questions or need help feel free to put a comment and I will try my best to answer everyones responses!

2 Likes

Thank you so much for this. Been wanting to add so many detailed houses into my server. But they didn’t load properly. This really helped

1 Like

you sir, are gonna be remembered as a legend in the future

1 Like

No worries sir.

1 Like

Not sure if you knew about this, but something that the resource is streaming changes store textures to from 24/7 to asda textures

hey @Bxrks .

Thank you for your addons, that is very helpful.
I saw that some props or vehicles were still not showing up on some YMAP I have installed on my server.
When teleporting where the object is supposed to be, there is nothing. I tried using CodeWalker to find the prop, and some of them are having names (and they show on the map) and some are having no name but only the Hash number, and do not show on the map.
What do you suggest to correct that? For one map, it is only a few, but for another one, it is most of the map which is not showing.

In my example I describe, the hash number is 2243400388. Supposed to be a vehicle, related to construction, work zone.

Thanks

Not sure if you knew about this, but something that the resource is streaming changes store textures to from 24/7 to asda textures

if xml is water .it cant be change to ymap . cant find ped or pickup to delete. can u help me?

i cant find the file anymore