Help with mysql when setting up server

Server Artifact Version:
Operating System (Windows/Linux):
Error screenshot (if any):
Crash files (if any):
Server config (server.cfg):
Path to server files:
Path to cfx-server-data files:

Describe your issue
What have you tried?

So i rented a server from zap, and used the ftp to insert redemrp. I thought i had gone through all the different steps to download and insert the relevant files and changed the config settings.

I of course cant be doing it correct as i keep getting this error on the console in zap.

script:redem_rolepla] [RedEM:RP] Database: Successfully updated database for version: 5
[ script:mysql-async] [ERROR] [MySQL] [redem_roleplay] An error happens on MySQL for query “SELECT * FROM version WHERE current=‘yes’”: connect ECONNREFUSED

Can anyone point me in the right direction as i assume its gone wrong somewhere with the sql set up and probably missing something really simple to you guys. (Im very green at this, apologies)

I have tried to delete and re-try all the steps again as per the installation instructions but i still cant seem to set it up correctly.

Thanks