FxDK | awaiting scripts

Hey guys,

Every time I start my server, I’ll get stuck in the waiting script session and I’ve got everything set up right, so what’s wrong?

1 Like

If using canary, can you try creating new project now and see if that works?

1 Like

I have already created a new project and followed the instructions from cfx and reinstalled FiveM
(same problem)

Try reinstalling FiveM

1 Like

do you have the basic gamemode script active / enabled?

EDIT: Nevermind i see that you do

Try reinstalling fivem

OH WOW thanks for youre help :smiley: <3 i just reinstall FiveM like 10 times good job dude

for me it was session manager that was causing awaiting scripts so what i did was removing all the basic resources the project installed and replaced them manually GitHub - citizenfx/cfx-server-data: Data repository for CitizenFX servers. and now it works. This might be different for you so maybe just give it a try!

seems like you’re missing the webpack :slight_smile:

and also sessionmanager

Thanks my LocalHost is now working ;D

1 Like

Can confirm this HOWEVER it works totally fine with an empty project, once you created a resource + enabled it and you restart the whole FxDK, it’ll be stuck on Awaiting Scripts... to give some clues why it might happen.

I got Awaiting Scripts... when I didn’t set a valid spawnpoint.

I had the same problem a few minutes ago with a new project

I ‘fix’ it using ensure webpack in server-console to build webpack therefore the server was able to start session manager

After that, I’ve restart FxDk (I don’t know if it’s necessary or not)

I fixed it, i simply went ahead and rewrote the spawnmanager from scratch and now it works perfectly fine.