[FIXED] RedM don't start after changing API from Vulkan to DirectX (UI don't load)

Up to date? Yes
Legit or Pirate copy? Legit
Steam/Epic Games/Social Club? EGS
Windows version? 11 22H2
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any)


System specifications RTX 3060 Laptop, 11th Gen Intel(R) Core™ i5-11400H @ 2.70GHz , 16gb ram (8*2)
What did you do to get this issue? Change API to DirectX
Latest CitizenFX_log file https://pastebin.com/fTcXxUz7

If an issue with starting:
RDR2 folder screenshot

RDR2/x64/dlcpacks screenshot


Filepath to RedM folder

Did you try to disable/uninstall your Anti-virus? YES
Did you start Rockstar Games Launcher not as admin? NO

Also add what you already tried so far. Uninstalling RedM and Reinstall it, no success.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

if you find a fix plz let me know

Discord name is: Aqua#6147

Ok so I found a solution.
So, when switching to DirectX it will ~55% of the time switch to Intel UHD Graphics (or AMD equivalent) and due to the fact that it’s not powerful, you will not load the UI
But here the fix :slight_smile:

Go to the console (F8) :
→ Go to launch → SP → RDR3
→ Then the game loads press ESC
→ Go to settings → Graphics
→ Change the GPU (the first option) and the resolution or the API
→ Press Enter, then restart RedM

It’s fixed now!
Enjoy :wink: