[Fix] Rage Error: ERR_GFX_INIT

Firstly, thank you [cederbro]. The following is a fix to RedM not launching and prompting the user with the following error;

RAGE ERROR: ERR_GFX_INIT Failed to initialize graphics device. Please reboot or reinstall latest drivers.

Shameless Plug: [FIX] [RedM] How to Fix the RedM Rage Error: ERR_GFX_INIT Failed to Initialize Graphics Device - YouTube This video fetatured a quick run through on the fix.

[FIX] Under Documents>RockStar Games>Red Dead Redemption 2> Settings> System.xml (open in notepad.

Type Ctrl+F Type in Vulkan (If RDR2.exe has the same error) delete Vulkan and put DX12. Save

Now verify RDR2 now works. Skip if RDR2 was already working.

Copy that System.xml file.

Now right click on your RedM application and open file location. Got back from there to AppData, Then to Roaming, then to CitizenFX. Paste System.xml file in that folder, the go into the RDR3_Settings. Now also paste here too.

Exit all things and run RedM. Presto remember to thank CederBro

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!