FiveM Voice Chat Lags Behind

Environment questions

GTA V version: Latest
Up to date: Yes
Legit or Pirate copy: Legit
Purchased where - Steam/Rockstar Launcher/Epic: Epic
Windows version: 10
Did you try to delete caches.xml (not cache/!) and try again? Yes
System specifications: i5-9400, 1660 ti, 16gb ddr4 2933 ram
CitizenFX crash zip file (‘Save information’ on a crash):
logs/CitizenFX_log files:
.dmp files/report IDs:

Important parts

What is the issue you’re having?
My voice chat is lagging behind, I hear what players are saying up to minutes after it is actually said.
What are you trying to do?
Get my voice chat to be closer to real-time.
What have you tried already to fix the issue?
Reinstalling FiveM, reinstalling GTA V, Restarting PC/Router, Disabling Nvidia High Definition Audio, Clearing Cache, Updating Drivers
Error screenshot (if any):

What did you do to get this issue?
Nothing, it occurred on its own.
What server did you get this issue on?
Twin Peak Roleplay


Additional comments

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

I can actually replicate this. This issue occurs with nativeAudio disabled, but not with it enabled. It’s caused by just packet loss, being very noticeable at 10-30% loss on inbound UDP traffic. Pretty much puts the issue within MumbleAudioOutput. Requeueing your microphone often seems to have the affect of progressing the audio output stream.

Huh - the way jitter buffer polling is done for XA2 may be acting up, then?

I have an example fix that I’ll make a PR for in a minute. Not sure if you’ll want to accept it, but it does seem to work.

are you able to also send me this please?

I was referring to:
fix(voip/mumble): actively poll the jitter buffer in both modes by GlenCFL · Pull Request #697 · citizenfx/fivem (github.com)

It didn’t pan out due to very short audio cutouts. The exact issue is known; it’s just coming up with the right solution.

Could you direct me in the correct direction to solving my issue? I apologize if I am just blind but I don’t see anything in the post you linked that I can change in my settings.

Unfortunately, it’s mostly out of your hands. “nativeAudio” is a feature that the Twin Peak server owners themselves could enable to alleviate this, but there are other potential issues in doing so.

Hopefully this issue is fixed within the FiveM client itself soon. The link is regarding that.