FIVEM dropping fps and 100% CPU usage

IF YOU DO NOT FILL THIS OUT, YOUR TOPIC WILL BE UNLISTED AND CLOSED

To receive support, please fill out the following template, and remove this top text.


Environment questions

GTA V version: last version
Up to date: last version
Legit or Pirate copy: legit
Purchased where - Steam/Rockstar Launcher/Epic: steam
Windows version: Windows 10 home 20H2
Did you try to delete content_index.xml and try again? yes
System specifications: Notebook Acer nitro 5, i5 9300H, gtx 1650, 1x8 DDR4 2666MHZ, 128GB SSD and 1TB HD

Important parts

What is the issue you’re having? I have a problem with gta rp when i’m playing my cpu is taking 100% and fps is dropping, other games run normally

What are you trying to do? play GTA RP

What have you tried already to fix the issue? i put the low graphics, tested other games, finished some processes

What server did you get this issue on? Be specific and name some, ‘all of them’ by itself isn’t useful! Brazilian servers Rise RP and South RP


Additional comments

i bought the notebook last week, I have another 2 pcs, an i5 2400, 2x4 8GB DDR3 1333MHZ, GT 730 2GB and 240 HD the game worked normally before burning the pc, my other pc is a ryzen 5 3600, 16GB 3000MHZ, GTX 1660 super, 512GB ssd nvme and 2TB HD that also runs normally

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

  1. Does this break on the testing server as well? connect "https://fivem.net/"
  2. Can you provide a .etl trace file? https://tinyurl.com/etwtracing

on the test server works normally
i separated the etl file for you
etwtraces.rar (49.2 MB)

Right, it seems that you are somehow using a total of 17 GB of ‘RAM’ while you only have 8, and you probably have the page file on the slow HDD.

If you have your GTA texture quality set to ‘Normal’, try setting it to ‘High’ instead. ‘Normal’ is bugged and leads to memory use being around 1.5-2x what it should be, which hurts 8 GB RAM systems a lot.

If this leads to any cases with the map not loading in the server you’re playing on, tell the server owners to check and fix the cases in their server console that mention oversized assets.

i set the graphics high and really improved it, i’m going to test for a while longer and check if there are any changes, thanks man