FiveM doesn't load privately hosted server

IF YOU DO NOT FILL THIS OUT, YOUR TOPIC WILL BE UNLISTED AND CLOSED

To receive support, please fill out the following template, and remove this top text.

GTA V version? Latest on steam
Up to date? Yes
Legit or Pirate copy? Legit
Steam/CD/Social Club? Steam
Windows version? Windows 10 Pro
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any)
System specifications 16GB RAM, core i7-3770, Asus 1060 3GB
What did you do to get this issue? I tried to direct connect using my server IPv4 and port
What server did you get this issue on? My own
CitizenFX crash zip file
CitizenFX.log file
.dmp files/report IDs

If an issue with starting:
GTA V folder screenshot
GTA V/update/x64/dlcpacks screenshot
Filepath to FiveM folder
FiveM client folder screenshot
Which antivirus/firewall software are you using?
Did you try to disable/uninstall your Anti-virus?

Also add what you already tried so far.
I don’t know where to find the CitizenFX crash zip file or the .log file.
I have tried turning my servers firewall off as well as port forward different ports, but the error stays the same;
Failed handshake to server [Internal server ip]:[Internal port] - recieved HTTP/0.9 when not allowed - Curl error code 1 (Unsupported protocol)

I don’t use any UDP connections only TCP, I have set the port in the cfg file in the server directory to the same as the server and port forwarded so my friends can join. I am really stuck and tried everything I can think of, any help would be appreciated.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

UPDATE: I fixed the error, it turns out that in the .cfg file for the server I made game server port the same as the PC, which made Curl go into HTTP mode which is unsupported. By changing the game server port back to 30160 I was able to get my client to connect and load the map.

Thanks for reading, and I hope this helps anyone who has the same or similar issue to what I had!