[ESX Legacy] NUI Doorlock (item, lockpick, and job/grade authorisation) - audio and image display

It uses spawnmanager so cui character doesn’t work properly and multicharacters need slightly different changes.

hi found an issue where the door has set but nothing is coming up but i am using gabz mrpd but even that config is not working i might be doing something wrong unsure as to the problem.

You have an error right there in the console, and it looks like line 415 which does not contain doorType; you tell me the problem.

yeah i try to set single door but it says this error which you found in my image above which i forgot to say soz


also the lock symbol does no come up so i cant lock or unlock the doors for some reason but i have put my job authorisation in as put in the image below.

413 still doesn’t contain doorType, so…

Thanks for this great resource :smiley:

How do you edit existing doors??

Just modify the config files. There are options for doors that you can only set in there (fixText, manually setting textCoords, autoLock, lockpick, etc).

great tool and everything seems working fine. Unfortunately I have one issue with items. I added key_pbh as an item to my inventory but when I try to use it I get the following error message:

SCRIPT ERROR: @nui_doorlock/server/main.lua:67: attempt to index a nil value

The item is also integrated in the items database and visible in my inventory.

Any ideas?

1 Like

OK, I fixed the issue for me. Replaced line 75 in server/main.lua

count = xPlayer.getInventoryItem(k).count

into

count = xPlayer.getInventoryItem(v).count

I keep getting this error in the client/main.lua

Having the exact same issue.

Same here.

same here!

1 Like

i have the new version but i get an error when i run the script

error : @nui_doorlock/server/main.lua:40: in main chunk

So don’t use the latest version, which specifically states it is for ESX Legacy?

I’ve disabled github issues because it’s all the same garbage. I will drop support for this resource again if I have to keep dealing with the same questions.

when i set my authorized grade to 4 (boss) every grade is still able to open the door, any reasons why?

something something low iq

what do you mean sorry? im still new to coding and learning

any help with the grades anyone?