[ESX] Inventory inspired by Trsak ❤

any reason for some shops dont open ?? like police shop… ive double checked the job name in config ?!

Hey t0sak! the Norwegian server i try to join on GTA5, says i have to be whitelisten, and that i have to contact, you, i didnt see a PM button anywhere so i found this tread instead. im 36 years old, i do kinda wanna play right now if it’s possible. Jeg er norsk, I’m norwegian, im getting confused tho if i should use my native tounge on this treads, seeing that everyoneelse writes in english! :slight_smile: Can you help me tho?

Anyone able to make the illegal shop use dirty money?

I cant seem to find where I can change the currency to $. Does anyone know what file its in?

1 Like

DP_Inventory

1 Like

I am having the same issue as well. Any fix? Thanks in advance!

DP_Inventory\HTML\JS\inventory.js Starts at line 396 I believe.


How to fix that ? Is this inventory still working ?

Did you add weapons as items? Scroll up there is a SQL file that you need to put in your database

This is great since it works, but only one problem, my weapon wheel is not working anymore. im using ESX Legacy and i did /giveitem for weapon and still doesn’t work. Any way to make weapon wheel work while using inventory?

Because of the fast slots, the keyboard’s 1-5 number keys are disabled, and this will also disable the weapon wheel

1 Like

How would someone be able to take their weapon out?

Put the weapon in the fast slot, but as far as I know, these weapons need to be inserted as items

1 Like

Yeah… I figured. Now i’m stuck on figuring out how to convert weapons into items. Know any guide to that? Thanks for your replies btw

just follow the instruction, link below

line 67, INSERT INTO items (name, label, weight) VALUES

1 Like

Ah thanks, already had it in the database just couldn’t see the weapon names. Pretty nice, and for the images not showing in the inventory, i would have to add those myself yes?

Yes, put the images to DP_Inventory\html\img\items

1 Like

Hi, congratulations on this script, really well done. I just tried it and would like to ask you how I can view ammo as an inventory item. I used esx_weaponsync but with the script it doesn’t work, if I try to reload for example ammunition_pistol, it does the animation but doesn’t load the ammo.

Good time of day, tell me. What could be the problem.
I try to rob a player and nothing happens.
That is, there is a progress bar, then there is no one.
I don’t get any errors anymore.
Initially, I did not understand why the hash of the weapon did not turn out, then I realized that it was necessary to remove the weapon and get it again.
The hash of the weapon was obtained, but no interaction.
This is the clients\weapons.lua 175-220 line.

Not correct database added