Error:no port was configured

So i have a server running on a VPS. it was working fine earler today and now when i went to go start it i was given this error


Help?

Did you change your citmp?

It shouldnt have been. but it could have. there are more then one person that has accsess to it.

@Gizmos said in ERROR:NO PORT WAS CONFIGURED:

It shouldnt have been. but it could have. there are more then one person that has accsess to it.

Well… first verify that, since that’s where the port it configured.

is there a default port it should be on? its listing right now +ListenPort: 30120

That’s correct. 30120 is default…

Then what could be the problem?

Should be like this;

ListenPort: 30120

PreParseResources:
    - mapmanager 

etc. etc.

+ListenPort: 30120

PreParseResources:
    - mapmanager

AutoStartResources:
    - fivem
    - mods
    - loadingscreen
    - whitelist
    - chat
    - spawnmanager
    - fivem-map-skater
    - baseevents
    - ambulance
    - fbi
    - fbi2
    - firetruk
    - police
    - police2
    - police3
    - policeold1
    - sheriff
    - sheriff2
    - policet

RconPassword: 

Hostname: ^1Los Santos County Public Safety ^2LibertycountyDPS.enjin.com

Game: GTA5

PlatformServer: updater.fivereborn.com

ScriptDebug: true

DebugLog: true

Announce: true

# enjoy viiv
#Imports:
#    - ConfigURL: http://cache.lilycove.hacks.re/exports.json

# the following is an example for resource download offloading
#Downloads:
#    all:
#        BaseURL: http://cache.lilycove.hacks.re/
#        UploadURL: ftp://citizen:[email protected]/

DisableAuth: true # Keep this off to avoid terminal bullshit
DisableScriptHook: false

Delete the +

By the way, what’s with all the resources :sweat_smile:

thank you for editing some parts out for me :wink:

Oh we love them Lol and thank you. the server is up and running! :smile:

@Gizmos said in ERROR:NO PORT WAS CONFIGURED:

Oh we love them Lol and thank you. the server is up and running! :smile:

Are these seperate resources for each individual vehicle?

Yes if i’m correct

@Gizmos said in ERROR:NO PORT WAS CONFIGURED:

Yes if i’m correct

Isn’t neccesary you can just put them in 1 stream.

Like;

Resources\vehicles\

Resources\vehicles__resource.lua
Resources\vehicles\stream

Resources\vehicles\stream\ambulance
Resources\vehicles\stream\fbi
Resources\vehicles\stream\fbi2
Resources\vehicles\stream\etc.

Resources\vehicles\stream\ambulance\ambulance.ytd
Resources\vehicles\stream\ambulance\ambulance.yft
Resources\vehicles\stream\fbi\fbi.ytd
Resources\vehicles\stream\fbi\fbi.yft

And then add;

AutoStartResources:
    - fivem
    - mods
    - loadingscreen
    - whitelist
    - chat
    - spawnmanager
    - fivem-map-skater
    - baseevents
    - vehicles