Discord not linked with FiveM

I have to Authorize and deauthorize FiveM from Discord every day to play the RP server. My discord is linked in FiveM. But still shows me the same error that Discord is not linked. then I had to Deauthorize FiveM from Discord and uninstall it from my PC then delete flies from appdata and reinstall Discord again then authorize again.
I have also tried to uninstall fiveM de-link from my account and installed it again but same issue.
I thought it was my laptop issue so I re-installed my windows also.

Please help with this thing, as I am tired of uninstalling and installing Discord again and again.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

in short you are probably doing to much than what is needed to fix the issue. In most cases you should just have to restart your computer, open discord(wait for it to load fully), then open fivem. This is a common error I also receive when attempting to connect to a server that utilizes a script like Badger_Discord_API.