CURL error code 18 (transferred partial file)

GTA V version: Latest
Up to date: Yes
Legit or Pirate copy: Legit
Purchased where - Steam/Rockstar Launcher/Epic: Rockstar
Windows version: 10
Did you try to delete content_index.xml and try again? No
System specifications: Ryzen 5 2600, GTX 970

Important parts

What is the issue you’re having?
CURL error code 18

What are you trying to do?
Join a specific server

What have you tried already to fix the issue?
Clearing Cache
Using a VPN (saw it worked for someone)
Reinstalling FiveM

Error screenshot (if any):
https://prnt.sc/1032q70

What did you do to get this issue?
Join a server

What server did you get this issue on? Be specific and name some, ‘all of them’ by itself isn’t useful!
MapleHearts, a new whitelist server I’ve seen.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot: