Curl error 7, handshake failure

To receive support, please fill out the following template, and remove this top text.

GTA V version? Latest
Up to date? Yes
Legit or Pirate copy? Legit
Steam/CD/Social Club? Steam
Windows version? Windows 10
Did you try to delete caches.xml and try again? yes
Error screenshot (if any) http://i64.tinypic.com/30l15qv.png
System specifications Not important to the issue
What did you do to get this issue? Join my own hosted server
What server did you get this issue on? My own testing server
CitizenFX.log file -
.dmp files/report IDs -

I have hosted a server on ubuntu, but I keep getting the error shown in the screenshot. I have opened the ports, which did not help. Does anyone have a clue what I can do? This error happens when I try to join my own hosted server on a vps.

Error: failed handshake to server *** - Failed to connect to *** Timed out - CURL error code 7

So it’s not a common problem?

Tried to disable the firewall, tried to open various ports or use different ports, tried to disable apparmor or related selinux functions. No results

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.