Crashing with violet-speaker-georgia or eleven-stairway-single around Legion Square

GTA V version: Newest (tuner dlc)
Up to date: Yes
Legit or Pirate copy: Legit
Purchased where - Steam/Rockstar Launcher/Epic: Rockstar
Windows version: 10
Did you try to delete content_index.xml and try again? No
System specifications: RTX 3090, 64 GB Ram, i9-7920X
CitizenFX crash zip file (‘Save information’ on a crash): (1.7 MB) (forced Tuner DLC) (1.6 MB)

logs/CitizenFX_log files: In the ZIP
.dmp files/report IDs: In the ZIP

Important parts

What is the issue you’re having?
Players are crashing near legion square with the error “violet-speaker-georgia” or when tuner dlc forced “eleven-stairway-single”. The crashes are both the same (MapDataContents_Remove (0x27)) I think it has something to do with dynamic props after driving into them.

What are you trying to do?
I want to sort out the issue and fix it.

What have you tried already to fix the issue?
I did a debug for 10 hours to sort out the problem. I have read about that broken MLOs or Ymaps could be the issue. I removed all MLOs, cleared the cache and server cache. But still a lot of crashes on legion square.

Error screenshot (if any):
Well i did a whole video of it. Took me 6 minutes to crash the game: Crashing with violet-speaker-georgia or eleven-stairway-single around Legion - YouTube
Btw. i removed all Ymaps or MLOs before recording this video.

What did you do to get this issue?
The best way to force this crash is to noclip around or drive fast around legion square and drive into the street lights, bins etc… Another way to force it is to teleport away from it and teleport back to legion square. You need to take some time to trigger this crash. Sometimes you need 10 minutes, sometimes 20 minutes.

What server did you get this issue on? Be specific and name some, ‘all of them’ by itself isn’t useful!
On my own whitelisted Server. I took a look into my logs and saw, that we had this crash since October 2020. But the issue got bigger when forcing the game version to tuner dlc. The server is running on OneSync Infinity and on artifact 4292.

Well i hope this will help to fix this issue. I did a 10 hour debug but still can’t find the problem.


Did you disabled the map-modifications you are using on/near the Legion Square and then tried to trigger the error again?

*incase you do have map-modifications there ._.

1 Like

As i said: I removed all Ymaps & MLOs on the server. I tested the same thing on a 100% vanilla FiveM server (local hosted) and didnt get any problems. So it looks like there is a script triggering this issue.

I’m sorry I missed that.

Im going to look into the crash files you provided and see what i can do about it :grinning_face_with_smiling_eyes:

1 Like

some info; I saw another post from you where you mentioned a proxy (to prevent DDOS attacks).
A non-local IP can be seen in the crash log. If this is the IP you want to hide through the proxy, you should delete this file :slight_smile:

Both crash logs refer to the same cause (cpp file and line in -GamePrimitives_MapData). However, this file contains the streaming handler, so I cannot say for sure whether it is causing a script or an corrupted/damaged(standard) map modification.(im not really into the structure and the way how the github project works)
But anyways, it is this “MapDataContents_Remove” what causes the error.
And as far as I understand the error and the GamePrimitives_MapData.cpp, it failed to unload a map.

Ive looked into the .dmp file an read over this: 0xC0000005. It is an Access Violation error.It means that your program just tried to read, or write, in a section of memory that it has no access to. I think that an attempt was made to unload a map which was not loaded.
And i think that cant be fixed by us normal server owners, but has to be changed in the code.

thats my thought, im not pretty sure but that is it what seems to be logical to me.

1 Like

Everything good its just the proxy ip and we will change the ip in a few days.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.