CFC SRV Record Error? Server is loading or failed to load (Custom port)

We have created an SRV record for our server, which I have confirmed works. I am able to successfully load into the server using connect in the F8 console with the domain but I am being presented with this error [Ref Image]

We are currently using a custom port [30100] but it is displaying port [30120].

Endpoints are appropriately defined in the server.cfg with port 30100 for TCP and UDP.

As mentioned, the port displayed is incorrect. The correct port is referenced, the connection is established, but something different is displayed.

Is there anything I could be missing here?