Can't start the Server because can't find auto-started resource

Just installed FiveM Server with mono-complete.

Here is what it say when I start the server:

2017-05-29 20:14:08.4591|ERROR|CitizenMP.Server| at [U] CitizenMP.Server.Resources.ScriptEnvironment.Create()
2017-05-29 20:14:08.4591|ERROR|CitizenMP.Server|Resource fivem-map-skater caused an error during loading. Please see the above lines for details.
2017-05-29 20:14:08.4591|INFO|CitizenMP.Server|Starting game server on port 30120
2017-05-29 20:14:08.5269|INFO|CitizenMP.Server|Starting HTTP server on port 30120
2017-05-29 20:14:08.7170|ERROR|CitizenMP.Server|Could not find auto-started resource chat.
2017-05-29 20:14:08.7170|ERROR|CitizenMP.Server|Could not find auto-started resource spawnmanager.
2017-05-29 20:14:08.7170|ERROR|CitizenMP.Server|Could not find auto-started resource fivem-map-skater.
2017-05-29 20:14:08.7170|ERROR|CitizenMP.Server|Could not find auto-started resource baseevents.
2017-05-29 20:14:08.7170|ERROR|CitizenMP.Server|Could not find auto-started resource rconlog.
2017-05-29 20:14:08.7170|ERROR|CitizenMP.Server|Could not find auto-started resource hardcap.
2017-05-29 20:14:08.7170|ERROR|CitizenMP.Server|Could not find auto-started resource scoreboard.

Hope I can get help.

Tell me if you need Screenshots or something.

What’s your mono version?

Thanks for the fast reply.

I got Mono version 5.0.1.1

Hope it’s the right one.

You can look at the official website to help you install it

Exactly this version is installed.

Try installing Mono 4.8. I don’t believe 5.0 is supported just yet.

Sorry I forgot to write the rest ahah. Mono 5.x is not compatible, you have to downgrade to the latest 4.x version 4.8.1. You can look at the official site to see how to install it

Hm damn it ^^ Can I just override the installation or need I to remove it first? :slight_smile:
No problem, you’re welcome and thanks.

You need to uninstall it completely. Ubuntu / Debian -> sudo apt-get autoremove mono-complete and after edit the mono repository to install the 4.8.1

Now I changed the file named mono-official.list and put in there:

deb Index of /repo/debian/dists/stable-wheezy/snapshots/4.8.1 wheezy main

But now I have installed version 3.2.8


EDITED (solution):

Rewrite it to

deb http://download.mono-project.com/repo/debian wheezy/snapshots 4.8.1/main

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.