Can't Load into RedM - Game Ownership Issue?

I have the same copy of RDR2 on both Steam and Rockstar (I own the deluxe version of the game, on both platforms, legitimately).

Prior to buying RDR2 on Steam (around mid December I think it was), I’ve been able to load up RedM and connect to servers/play fine, no issues other than the usual once in a while need to remove cache files or relaunch Rockstar or RedM yada yada.

I tried to load the game up today, using Rockstar as usual (the game’s not installed on Steam, and never has been), and I’m hanging at loading in to every server I try. I can connect to the servers with no issue, reach the sepia fadein/fadeout images with the lower right gun chamber rotating icon as usual - but the game never loads in. Basically, infinite loading.

No error messages, no crashing, nothing off-kilter in F8, and no issues prior to owning RDR2 on Steam.

Clearing caches, logging in and out several times, and even clean installs of RDR2 and RedM (on a completely different machine - this laptop has never run RedM or RDR2, and yet the same issue is happening on my laptop and desktop which has never had a problem until now) - hasn’t worked.

Could it be that owning the game on both Rockstar and Steam is the issue here, and that I just can’t run RedM with the game in both libraries? It’s never been installed through Steam, it is only present in the library. I’ve checked the CitizenFX.ini file, and it points to the Rockstar install EXE.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

Interesting - this could indeed be an issue (having a Steam entitlement but never having activated it). You are running the Rockstar launcher in the background as per usual, right? Similarly, does it load fine if Steam is not running? (you can use loadlevel rdr3 in the F8 console to load a local session in case the server you usually join requires Steam)

1 Like

Good question, I will give that a shot and report back. At the moment, I’m installing the game on Steam on my laptop (and have uninstalled it from Rockstar). I plan on reinstalling RedM afterward too (which is also, currently uninstalled).

I’ve still got RDR2 installed on my desktop with RedM like it’s always been, so I’ll give this a shot there and see what happens. Thanks for the input!