Can't launch RedM: MTL didn't have SC SDK loaded

I have a next error appearing while launching RedM: MTL didn’t have SC SDK loaded.

RDR2 version? - 1491.50, RDO (Red Dead Online)
Up to date? - Yes
Legit or Pirate copy? - Legit
Steam/Epic Games/Social Club? Epic Games, Social Club
Windows version? Windows 10
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any)
CfxCrashDump_2024_06_09_13_38_59.zip (109.8 KB)

image

System specifications Intel Core i5, Nvidia GTX 1050
What did you do to get this issue? Downloaded RedM, launched both Epic Games and Rockstar Games Launcher. The RedM shows this error and afterwards launches RDO.
What server did you get this issue on? Haven’t even launched RedM succesfuly.
Latest CitizenFX_log file Don’t have it
.dmp files/report IDs Sent it under Error Screenshot section

Tried to clear cache, however there is no file as cache.xml anywhere. Searched in documents, appdata, game folder and RedM Files.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

Please, help me. There are many other posts about this problems. By resolving this problem you’ll increase the community and let more people in.

I HAVE SOLVED THE ISSUE! EVERYONE, WHO HAS SIMILAR ERROR, DO THIS!!

You have to create a separate user on your PC without microsoft account. Make sure it has a password. Afterwards, follow the steps:

  1. Open the cmd with administrator rights
  2. Write in next command /user:(USERNAME) “(LOCATION OF LAUNCHER.EXE)”
    For example, for me it was /user:redm “D:\Software\Rockstar\Launcher.exe”
    Make sure to insert a space before /user:…
  3. It will ask you to write your password. If you try to write it and the signs don’t appear in the cmd as you write - Don’t Worry, It should be like that. Just write your password once it asked you - don’t click on anything, JUST write the password using your keyboard. Afterwards press Enter.
  4. The Rockstar Game Launcher will be launched. You will be able to write your email and password and log-in.
  5. After you logged-in launch Epic Games or Steam without administrator rights (do everything, except cmd, without administrator rights).
  6. After it got launched, launch RedM - everything will be launched!

To launch a game, for example tomorrow, you have to launch the rockstar game launcher from the cmd. I recommend to copy the command into a text file and paste it each time.

Good luck, if you have troubles - write here!