Can't I play RedM withou steam, despite being a legit copy?

Hi. I bought RedM on Social Club and all the servers are asking me for Steam. Can’t I play RedM without Steam, despite it being a legit copy???

RDR2 version? I don’t know
Up to date? Probably
Legit or Pirate copy? Legiy
Steam/Epic Games/Social Club? Social Club
Windows version? 10
Did you try to delete caches.xml and try again? No. I just spent 10 minutes installing cache tho.
Error screenshot (if any)

System specifications i7-9700k, RDX something, i don’t know, it’s powerful
What did you do to get this issue? Nothing, I just installed RedM.
What server did you get this issue on? Any server
Latest CitizenFX_log file I don’t know how to get this
.dmp files/report IDs Don’t know

Also add what you already tried so far. Nothing

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

Certain servers have it set so you have to have it steam opened.

I did open Steam and I was having the same problem, but is somwhow fixed itself and I could enter. The problem now is the eternal loading. I can’t even join a simple golf server with 0 players. The loading doesn’t seem to end and I get no feedback on if something is happening or not. just the revolver rolling in the bottom right corner

Turn on Canary in RedM settings.

Thanks, this worked

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.