BUFFER_SHORTAGE error on playerconnecting

Hello guys, at the moment I’m working on a JS whitelist resource (actually the whitelist is part of a bigger resource). The way it works right now is by checking if the player is whitelisted in the database on playerconnecting. Now, if the player is whitelisted everything is ok, but if the player is not whitelisted this line of code gets executed:

deferrals.done("You are not Whitelisted.");

and this error appears in the console while the player is stuck in a deffer screen while connecting.

InvokeNative: execution failed: No current resource manager.
citizen:/scripting/v8/msgpack.js(29,12766): e
citizen:/scripting/v8/msgpack.js(29,15761): h
citizen:/scripting/v8/msgpack.js(29,13908): r
citizen:/scripting/v8/msgpack.js(29,6972): n.fetch
citizen:/scripting/v8/msgpack.js(29,12076): u
citizen:/scripting/v8/msgpack.js(29,7097): n
citizen:/scripting/v8/main.js(20,33): unpack
server/basic-functions-sv.js(51,17): isPlayerWhitelistedFunction


What is there to do? Right now I dont really have any idea on how this can be fixed.

Thanks in advance!

Apparently i solved it somehow. What i did was moving the mysql querry at the begining of playerconnecting then use a function to save the result into an object, then call deferrals.defer() and set a 100ms timeout after it

Basically what you have to do is add a delay between the sql query and the code that uses the data from the sql query. Now, i dont know what you’re trying to do so if this answer is not what you need, give some more information.

I finally found the solution, I deleted all my personal data from the database.

i also delete all the date from database but i still cant solve it

I took the latest version of the gcphone and esx_proprety and the error disappeared :wink:

hey i have same error
can anyone help me
i can send 10 steam random key to prison fix my error