[ADDON][ESX] Inventory HUD - Vehicle trunk 2.4.0

Hi, I’ve been trying to figure out a way to fix this on my own but I am a bit stuck.
There seems to be an issue of the trunk script depending on the esx_vehicleshop script. On my server I’ve disabled that since I use esx_advancedvehicleshop. The error in my server I get is this :

I’ve tested and if I turn esx_vehicleshop on again it works perfectly. If I have it off, then I am unable to put items in the trunk. It’s like there is no inventory for the trunk. I tried to find in the trunk script where to change the dependency but I couldn’t figure it out.

EDIT: Managed to dig up the solution, for anyone else stuck :
If you are using esx_advancedvehicleshop you should go to esx_inventoryhud → client → trunk.lua then search for isPlateTaken
If is “esx_vehicleshop:isPlateTaken” Change to “esx_advancedvehicleshop:isPlateTaken”

There are TWO places you need to change this. :sweat_smile: don’t be like me and change just one. The first place is to put in and the second is for taking out. Good luck!

How on earth (which file is it) do you change the button text to use, drop, give? My locales is still in en, however the only thing that still reads pouzit, dat, & zahodit… Doing a find in each file came up empty.

Please help. Thank you.

Hmtl>locales>CS and just erase that %$^* and add English is all i did :slight_smile: smooth brain ape solves another problem… TO THE MOON!!!

Hello I have problem.

Server callback “esx_inventoryhud_trunk:getInventoryV” does not exist. Make sure that the server sided file really is loading, an error in that file might cause it to not load.

How do I fix this error thank you for the help :slight_smile: I use everything as required and I still get the error

Would anyone know how to fix this issue by chance? The script works fine and then will break randomly causing us to restart and make all players lose there Inventories. This is the error code it pulls.

Hello,
I have the problem that I cannot pack any items in the trunk.
There is no error message and I couldn’t find a solution online.
I hope someone can help me and have a great day! :smiley: