Is there any change that add on will be supported? and when?

It’s already supported?

@Boss It is? how then?

@Boss hello?

Search the forums…

Add a vehicles.meta
Add a carvariations.meta
Add the ytd/yft files
Spawn the car by name

Like this? because this doens’t work

@Boss Or is it only client sided?

.meta files are clientsided.

Reference this post I made a few weeks ago. I believe this is what you’re looking for:

@Crowmedic I can’t get it to work, any help? i don’t have a carvariations.meta so what now?

@Crowmedic How did you do it acactly?

Using OpenIV, I pulled the vehicles.meta from update/update.rpf/common/data/levels/gta5

I pulled carvariations.meta from update/x64/dlcpacks/mpChristmas2/common/data

I then modified those files with the appropriate information for the vehicles I wanted to add into the game. (This step did not include adding the vehicle model data. That is streamed by the server)

I then placed the files in their appropriate locations within the fivereborn directory

Vehicles.meta goes in [Fivereborn Folder]/citizen/common/data/levels/gta5

Carvariations.meta goes in [Fivereborn Folder/citizen/dlc/dlc_mpChristmas2/common/data

Here is an example of how this works:

Say I want to add a vehicle. It’s called Tahoe. On the server side, I would create a folder and stream all the .ytd/ytf files. Make sure they are all named Tahoe.ytd/.ytf

On the client side: I would do as stated above. I would make sure that i entered data into the meta files and make sure that they all reference Tahoe.

If you would like an example of this, PM me on here an I will show you that it works on my own server.

@Boss I did what @Crowmedic said i needed to do but now my fivereborn gives the error: ‘‘Could not find some resources :(’’ what now?

@Boss Do you know how to solve this error?

Well I been looking for solution for add-on and I was able to add cars for five reborn thanks to @Crowmedic. Now I just looking for solution for car modification( tune) which is the [content.xml]. Not sure where to put the content.xml. The content.xml i use is from the dlc_christmas2.
By the way Pipje you should also put handling.meta for the car that you add.
Handling.meta =[Fivereborn Folder]/citizen/common/data. Hope it help.

Been trying to do this myself. Have a whole load of police vehicles I want to add as add on, and in single player, I need to edit the gameconfig with these edits:

<PoolSize value="20000"/>
<PoolSize value="1500"/>
<PoolSize value="500"/>
<PoolSize value="500"/>
<PoolSize value="600"/>
<PoolSize value="1900"/>
<PedsForVehicles_Base value="500"/>
<PedsForVehicles value="500"/>
<VehicleMemoryMultiplier value="900"/>
<VehicleUpperLimit_Base value="500"/>
<VehicleUpperLimit value="500"/>
<MaxVehicleModelInfos value="3900"/>
<MaxExtraVehicleModelInfos value="2400"/>
<PoolSize value="500"/>

I first started FiveReborn without this and it was crashing me on load, so it obviously wanted the limits raised, so I added this, it stopped crashing me. But now as soon as I go to the pause menu I have this crash

Out of game memory. Please reboot and restart the game.

I then added into the gameconfig thinking that it’s multiplayer so I likely need to add this option too. :

<VehicleUpperLimitMP value="500"/>

Still same issue. Anyone know if anything else I need to do?

In single player it works perfectly fine once I do that gameconfig edit, anything I’m missing for FiveR?

Edit: Downloaded this GameConfig, seems to of solved that, now still stuck on where I was before I had that issue pop up, vehicles are not being found at all despite doing my metas.

Edit 2: It was an error I did in vehicles.meta when I copied everything. I placed the added vehicles at the top inside another already there. Opps. So that’s all great. All is working, I just now need to work out what is different in that gameconfig compared to the settings I used first above.

So if anyone has issues, may be you want to have a gameconfig edited to raise the limits.

Update to that regarding the gameconfig. It all works great, but FiveReborn keeps overwriting the gameconfig for some reason every other time neaning I try load it crashes do I need to copy and replaceit over again to get in. Tried even with in the folder, but doesn’t seem to be something to do with the update server causing it, rather something in FiveReborn itself.

@Boss i work now but when i try a different add-on mod, it crashes without an error, the citizenFX log says this: ‘’[106612390] level hash match - was custom: 0’’ what does this mean?